forum.vmspython.org Forum Index forum.vmspython.org
Forum system
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Error during compiling

 
Post new topic   Reply to topic    forum.vmspython.org Forum Index -> MySQL for OpenVMS
View previous topic :: View next topic  
Author Message
dario.karlen



Joined: 13 Mar 2008
Posts: 4

PostPosted: Wed Mar 19, 2008 11:04 am    Post subject: Error during compiling Reply with quote

I've installed JPFs MySQL server 5.1 on a I64 VMS V8.3. The Server is running well, but when I try to compile and link a C program some errors occur.
I ve got an option file sql.opt:
MYSQL051_ROOT:[VMS.LIB]MYSQLCLIENT_MIXED.OLB/lib
MYSQL051_ROOT:[VMS.LIB]LIBZ_SHR32.exe/share
DKA0:[VMS$COMMON.SYSLIB]SSL$LIBSSL_SHR32/share
DKA0:[VMS$COMMON.SYSLIB]SSL$LIBCRYPTO_SHR32/share

and a compile/link program:
$ cc/float=ieee/iee=denorm/name=(as_is, trunc) -
/INCLUDE=SYS$COMMON:[MYSQL051.INCLUDE]mysql testmysql
$ link testmysql, -
INA_DISK:[INA.PROGS.DK]sql/opt, -
MYSQL051_ROOT:[VMS.LIB]MYSQLCLIENT_MIXED/lib

but when I try to run the compile/link program, some undefined symbols are detected:
ina > @linkmysql
%ILINK-W-NUDFSYMS, 2 undefined symbols:
%ILINK-I-UDFSYM, my_time
%ILINK-I-UDFSYM, thd_lib_detected
%ILINK-W-USEUNDEF, undefined symbol my_time referenced
section: $CODE$
offset: %X0000000000000270 slot: 2
module: client
file: MYSQL051_ROOT:[000000.VMS.LIB]MYSQLCLIENT_MIXED.OLB;1
%ILINK-W-USEUNDEF, undefined symbol my_time referenced
section: $CODE$
offset: %X00000000000002F0 slot: 2
module: client
file: MYSQL051_ROOT:[000000.VMS.LIB]MYSQLCLIENT_MIXED.OLB;1
%ILINK-W-USEUNDEF, undefined symbol thd_lib_detected referenced
section: $CODE$
offset: %X0000000000000000 slot: 1
module: my_thr_init
file: MYSQL051_ROOT:[000000.VMS.LIB]MYSQLCLIENT_MIXED.OLB;1
%ILINK-W-USEUNDEF, undefined symbol thd_lib_detected referenced
section: $CODE$
offset: %X0000000000000010 slot: 1
module: my_thr_init
file: MYSQL051_ROOT:[000000.VMS.LIB]MYSQLCLIENT_MIXED.OLB;1

symbol my_time in client is not defined, also my_thr_init (mysqlclient_mixed.olb).
Any ideas how I can solve this problem? I already posted this thread in the HP resource forum, they said JFP is on holiday this week and I should try it here as well. Maybe one of you also had this problem.
Thanks in advance.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forum.vmspython.org Forum Index -> MySQL for OpenVMS All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group