forum.vmspython.org Forum Index forum.vmspython.org
Forum system
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mysql first start memory error.

 
Post new topic   Reply to topic    forum.vmspython.org Forum Index -> MySQL for OpenVMS
View previous topic :: View next topic  
Author Message
mohcine



Joined: 15 Dec 2008
Posts: 12

PostPosted: Mon May 17, 2010 2:48 pm    Post subject: Mysql first start memory error. Reply with quote

Hi,

i'm trying to install Mysql 5.1.23 on Clustering Itaniums.
When i try to run the FIRST_START_MYSQLD DCL procedure the following error is displayed:

*****************
MYSQL> @first_run_mysqld
100517 14:36:02 [Warning] Forcing shutdown of 2 plugins
100517 14:36:08 InnoDB: Error: cannot allocate 524304384 bytes of
InnoDB: memory with malloc! Total allocated memory
InnoDB: by InnoDB 13573264 bytes. Operating system errno: 12
InnoDB: Check if you should increase the swap file or
InnoDB: ulimits of your operating system.
InnoDB: On FreeBSD check you have compiled the OS with
InnoDB: a big enough maximum process size.
InnoDB: Note that in most 32-bit computers the process
InnoDB: memory space is limited to 2 GB or 4 GB.
InnoDB: We keep retrying the allocation for 60 seconds...
100517 14:37:08 [ERROR] Plugin 'InnoDB' init function returned error.
100517 14:37:08 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
100517 14:37:08 [ERROR] /$1$DGA1/VMS$COMMON/MYSQL051/vms/bin/mysqld.exe: unknown option '--skip-bdb'
100517 14:37:08 [ERROR] Aborting

100517 14:37:08 [Warning] Forcing shutdown of 1 plugins
100517 14:37:08 [Note] /$1$DGA1/VMS$COMMON/MYSQL051/vms/bin/mysqld.exe: Shutdown complete

%NONAME-E-NOMSG, Message number 00000002
%DCL-W-SKPDAT, image data (records not beginning with "$") ignored
MYSQL>
*****************

I would like to allow 1 or 2G to the "innodb_buffer_pool_size". We have installed 6Gb of RAM into the Itaniums.

my current inndob configuration parameters are:
innodb_additional_mem_pool_size = 8M
innodb_buffer_pool_size = 500M
innodb_file_per_table = 1
innodb_log_buffer_size = 8M
innodb_max_dirty_pages_pct = 90
innodb_log_file_size = 500M

Could you help me to do that?

Thanks.
Regards.
Back to top
View user's profile Send private message
jfp



Joined: 12 Jul 2004
Posts: 618

PostPosted: Mon May 17, 2010 4:05 pm    Post subject: Reply with quote

You may try the 5.1.36 port by HP online:
http://www.vmsmysql.org/anonymous/kits/tmp/ia64/

JF
Back to top
View user's profile Send private message Send e-mail Visit poster's website
mohcine



Joined: 15 Dec 2008
Posts: 12

PostPosted: Mon May 17, 2010 4:49 pm    Post subject: Reply with quote

Hi JFP,

Sorry it's my mistake, the 5.1.36 version is the one that i'm trying to install.
I have increase the swapfile but it does not change anything.

Mohcine
Back to top
View user's profile Send private message
jfp



Joined: 12 Jul 2004
Posts: 618

PostPosted: Mon May 17, 2010 5:00 pm    Post subject: Reply with quote

You may try to check the MYSQL051_SRV account and increase Pgflquo.


JF
Back to top
View user's profile Send private message Send e-mail Visit poster's website
mohcine



Joined: 15 Dec 2008
Posts: 12

PostPosted: Mon May 17, 2010 5:22 pm    Post subject: Reply with quote

Ok,

i try to do it now.

I have another strange error.
I have configure the innodb_buffer_pool_size = 100M and when i start the FIRST_START_MYSQLD DCL procedure the following error is stored in the MYSQLD.LOG file:

****************
$ Set NoOn
$ VERIFY = F$VERIFY(F$TRNLNM("SYLOGIN_VERIFY"))
100517 17:07:34 [Warning] Forcing shutdown of 2 plugins
InnoDB: The first specified data file /mysql_database/datas/ibdata1 did not exist:
InnoDB: a new database to be created!
100517 17:07:40 InnoDB: Setting file /mysql_database/datas/ibdata1 size to 100 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Progress in MB: 100
100517 17:07:43 InnoDB: Log file /mysql_database/logs/ib_logfile0 did not exist: new to be created
InnoDB: Setting log file /mysql_database/logs/ib_logfile0 size to 500 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Progress in MB: 100 200 300 400 500
100517 17:07:57 InnoDB: Log file /mysql_database/logs/ib_logfile1 did not exist: new to be created
InnoDB: Setting log file /mysql_database/logs/ib_logfile1 size to 500 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Progress in MB: 100 200 300 400 500
100517 17:08:10 InnoDB: Log file /mysql_database/logs/ib_logfile2 did not exist: new to be created
InnoDB: Setting log file /mysql_database/logs/ib_logfile2 size to 500 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Progress in MB: 100 200 300 400 500
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
100517 17:08:24 InnoDB: Started; log sequence number 0 0
100517 17:08:24 [ERROR] /$1$DGA1/SYS0/SYSCOMMON/MYSQL051/vms/bin/mysqld.exe: unknown option '--skip-bdb'
100517 17:08:24 [ERROR] Aborting


100517 17:08:24 InnoDB: Starting shutdown...
100517 17:08:25 InnoDB: Shutdown completed; log sequence number 0 46409
100517 17:08:25 [Warning] Forcing shutdown of 1 plugins
100517 17:08:25 [Note] /$1$DGA1/SYS0/SYSCOMMON/MYSQL051/vms/bin/mysqld.exe: Shutdown complete

%NONAME-E-NOMSG, Message number 00000002
%DCL-W-SKPDAT, image data (records not beginning with "$") ignored
MYSQL051_SRV job terminated at 17-MAY-2010 17:08:26.07
Accounting information:
Buffered I/O count: 1514 Peak working set size: 127376
Direct I/O count: 107057 Peak virtual size: 905216
Page faults: 20691 Mounted volumes: 0
Charged CPU time: 0 00:00:16.67 Elapsed time: 0 00:00:52.39
****************

Regards
Mohcine[/b]
Back to top
View user's profile Send private message
mohcine



Joined: 15 Dec 2008
Posts: 12

PostPosted: Mon May 17, 2010 5:51 pm    Post subject: Reply with quote

It seems that the "skip-bdb" (MY.CNF) is not supported.

I have increase MYSQL051_SRV account Pgflquo parameter to 1000000, but it does not change anything.

it work well when i configure innodb_buffer_pool_size = 100M but not when i put it to 500M.

Mohcine
Back to top
View user's profile Send private message
jfp



Joined: 12 Jul 2004
Posts: 618

PostPosted: Mon May 17, 2010 6:14 pm    Post subject: Reply with quote

If 1000000 doesn't work try 2000000 and so on...

JF
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forum.vmspython.org Forum Index -> MySQL for OpenVMS All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group