forum.vmspython.org Forum Index forum.vmspython.org
Forum system
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

LDAP TLS

 
Post new topic   Reply to topic    forum.vmspython.org Forum Index -> Python for OpenVMS
View previous topic :: View next topic  
Author Message
urs mantel



Joined: 02 Nov 2010
Posts: 16
Location: Switzerland

PostPosted: Mon Feb 07, 2011 10:14 pm    Post subject: LDAP TLS Reply with quote

Hello Jean-François,

I'm using the LDAP module for read access.
Now I should do updates on the LDAP Server - so encryption is now
mandatory.

I'm trying to get the TLS running - but the LDAP seems to be built without TLS support.

A check for TLS returns 0
Code:
ldap.TLS_AVAIL
0


Is TLS available in VMS Python LDAP, am I missing something?

(in the VMS C LDAP (Utility Routines) TLS is implemented and works - the connection is encrypted - so the server side works)


Thank you,

Urs
Back to top
View user's profile Send private message
jfp



Joined: 12 Jul 2004
Posts: 633

PostPosted: Tue Feb 08, 2011 9:39 am    Post subject: Reply with quote

Hello Urs,

VMS LDAP doesn't provide all the material to build the Python LDAP module.
So the module is build using a port of openldap 2.3.39.

And this port is build without support for TLS.

I have update the port to include support for TLS, seem to build correctly on AXP, will check on IA64.

I will put new Python LD images on line later.

JF
Back to top
View user's profile Send private message Send e-mail Visit poster's website
jfp



Joined: 12 Jul 2004
Posts: 633

PostPosted: Wed Feb 09, 2011 10:42 am    Post subject: Reply with quote

Hello Urs,

I have put online a new version of the LD images which include support of TLS in the ldap module.

Code:
$ python
Python 2.5.4 (r254:67916, Feb  8 2011, 19:52:31) [DECC] on OpenVMS
Type "help", "copyright", "credits" or "license" for more information.
>>> import ldap
>>> ldap.TLS_AVAIL
1
>>>  Exit

sg1>


Let me know if this work.

JF
Back to top
View user's profile Send private message Send e-mail Visit poster's website
urs mantel



Joined: 02 Nov 2010
Posts: 16
Location: Switzerland

PostPosted: Wed Feb 09, 2011 11:58 pm    Post subject: Reply with quote

Hello Jean-François,

Thanks for the fast fix,

preliminary tests confirmed that the encryption now works. On the wire there is no more plain text visible - so I guess the encription is working.

I will do more tests at the next weekend, more on
Code:
OPT_X_TLS_REQUIRE_CERT, OPT_X_TLS_NEVER, OPT_X_TLS_CACERTFILE
and the other options.


Urs
Back to top
View user's profile Send private message
jfp



Joined: 12 Jul 2004
Posts: 633

PostPosted: Thu Feb 10, 2011 7:41 am    Post subject: Reply with quote

Hello Urs,

As I haven't done any test, I'm happy to know it works Very Happy

Any feedback will be welcome.


JF
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forum.vmspython.org Forum Index -> Python for OpenVMS All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group